Jump to content
FieldForcer

Warning 594: Due to rounding errors the solution may be totally invalid

Recommended Posts

Hello,

I ran a simulation at 60 Hz with no dielectric, just FreeSpace and PEC material. I get Warning 594.

 image.png.e7d7c4382d9ac9203aa759f887d83798.png

*.out file reports following about warning:

image.png.ddeda5b102580855353c749dda4688e0.png

 

How do I get rid of this warning?

 

Thanks,

FieldForcer

Share this post


Link to post
Share on other sites

Hello FieldForce,

 

The first thing that I would do is to activate low frequency stabilisation. Activating it should get rid of the warning. The *.out file explains quite clearly what the problem is, so no need to explain it further.

Share this post


Link to post
Share on other sites

Hello JIF,

 

Thank you very much for replying to my post. I activated low frequency stabilization in Solution Settings. And the warning disappeared. Still I have two more warnings 509, and 510  in .out file.

image.png.4e90011e92e1559d5e4eae67b8dbc9ff.png

 

My model has a 1V voltage source at a single port.  How do I get rid of these warnings?

 

When I simulate a current source (large voltage source with large load), solver doesn't give such warnings.

 

Thanks,

FieldForcer

Share this post


Link to post
Share on other sites

Hi
There are two things that you could try:

  • Activate double precision
  • If the model has a wire loop and the two loop terminations touch vertices of the same triangle, refine the mesh so that this is not the case (I doubt that this is the issue that you have, since FEKO has a test for it).

If that does not work, someone with more low frequency experience should try to help.

 

15 hours ago, FieldForcer said:

When I simulate a current source (large voltage source with large load), solver doesn't give such warnings.

Well, based on the error message this is expected. You are increasing the real part and thus the warning is not triggered, but that does not mean the real part of the model input impedance is any more accurate - the point is, the real part is extremely small (not radiating) and the value that is calculated as the real part could be inaccurate (but it will be a very small number). Maybe the real part of the input impedance is not important in your case?

Share this post


Link to post
Share on other sites

Hi JIF,

 

On 7/21/2018 at 3:17 AM, JIF said:
  • Activate double precision

I activated double precision, and it does not fix warnings because warnings 509, and 510 both show up in *.out file. 

Quote
  • If the model has a wire loop and the two loop terminations touch vertices of the same triangle, refine the mesh so that this is not the case (I doubt that this is the issue that you have, since FEKO has a test for it).

I used Fine mesh option, and both warnings stick around. 

 

I continued investigating field patterns in my model. I simulated current source in two separate models; first model has two coils and second model has two coils with a sphere. Properties of sphere are free space. Ideally I should get same field patterns, but I get different results. 

My model without sphere is:

Model_of_TwoCoils.thumb.jpeg.d01ec08199d921566dec628f21675d57.jpeg

I get following result - X-axis is distance from center of axis across two coils in negative X-direction(negative U-vector), 

1710550079_Theta90Phi180.thumb.jpeg.8e4494ca9a69bd73c2ac4d198cc1f868.jpeg

 

After inserting a free space sphere, my model is:

SphereModel.thumb.jpeg.e18dc1b90df9385141f261bf2c75ed14.jpeg

I get completely different pattern as well as values.

1317636907_EH-fields(theta90Phi180).thumb.jpeg.39e40a0796d8f1ad401a499b60be504d.jpeg

 

Shouldn't I expect above results to be exactly identical? 

 

FieldForcer

Share this post


Link to post
Share on other sites

Hi Torben,

 

4 hours ago, Torben Voigt said:

For very low frequencies / electrically very small models, the VEP should be much more stable for dielectrics than the SEP (even if the properties are freespace).

  1. For sphere with free space property, I specified MoM with VEP as well as low frequency stabilization. I get following error for frequencies of 60Hz, and 1kHz both:image.png.5281ca7fd7545c6946f03f4ffe161032.png             MoM with VEP don't work with free space. 
  2. When I change dielectric property of sphere to water, I don't activate low frequency stabilization, but MoM with VEP works without error 16810. However following warnings are displayed:

           image.png.9a925207a623311ea8cc4d3f593c936c.png

 

 

Share this post


Link to post
Share on other sites

Hi FieldForcer,

 

Sorry for being imprecise: With "properties are freespace" I meant a dielectric with properties of freespace (eps_r = 1, tand = 0). I was referring to

On 7/24/2018 at 4:17 AM, FieldForcer said:

first model has two coils and second model has two coils with a sphere. Properties of sphere are free space. Ideally I should get same field patterns, but I get different results. 

I assumed that you tried to solve the sphere with SEP, so I recommended VEP.

 

Regarding the Singular field errors, which version of FEKO are you using? In case it's the current version 2018.0.2 I would have to look into it. Is it posiible to attach the model?

Share this post


Link to post
Share on other sites

Hi Torben,

 

Thanks for your reply. 

Quote

With "properties are freespace" I meant a dielectric with properties of freespace (eps_r = 1, tand = 0).

I don't see a difference because eventually they both are free space. Nevertheless, I created a dielectric and assigned it properties of free space with eps_r=1, tand=0.   

image.thumb.png.05fbfab037bc3fb5afd18f1b18893097.png

Solver accepted FreeSpaceDielectric for solution with VEP method. CEM validate detected no error as well.

When I save project files, I see image.png.cfe0e6bb89d5eefb42e97e0a4aa03f47.png.

 

 

Quote

Regarding the Singular field errors, which version of FEKO are you using? In case it's the current version 2018.0.2 I would have to look into it.

I have 2017 version with Build date in 2018 image.png.22d67a6cee049ab432b021bfb4d06db6.png.

 

Quote

Is it possible to attach the model?

I have attached my model.

 

FieldForcer

Sphere.cfx

Share this post


Link to post
Share on other sites
13 hours ago, FieldForcer said:

Solver accepted FreeSpaceDielectric for solution with VEP method. CEM validate detected no error as well.

This makes sense. If you want to model free space, not SEP or VEP. So, when there is no dielectric, don't set it to VEP. You are trying to model nothing with something.

 

13 hours ago, FieldForcer said:

Regarding the Singular field errors, which version of FEKO are you using? In case it's the current version 2018.0.2 I would have to look into it.

The singular fields are probably due to you requesting points on the surface of a PEC triangle. Either ignore the warning or move the near field request point.

Share this post


Link to post
Share on other sites

Hi JIF,

 

Quote

This makes sense. If you want to model free space, not SEP or VEP. So, when there is no dielectric, don't set it to VEP. You are trying to model nothing with something.

It seems you are suggesting that free space dielectric doesn't need to be set to VEP, and that free space dielectric works well with SEP. However since frequency is low, I had to activate low frequency stabilization that works only when dielectric bodies are set to VEP. For example, if I use dielectric body with SEP and activate low frequency stabilization, Error 38490 pops up.

image.png.76d0e81b3d9c8dd2f449682485db818f.png

 

Quote

The singular fields are probably due to you requesting points on the surface of a PEC triangle. Either ignore the warning or move the near field request point.

As I mentioned in 4th reply earlier, these errors do not come when I change properties to water, not with PEC body. It may be at the interface where PEC body meets dielectric body.

image.png.f5e1ecda018d42925ed7e9934604de9c.png 

Share this post


Link to post
Share on other sites

Hi Torben,

 

Quote

...a distance of 1.5 x edge length of the mesh on the surface.

With Fine mesh and VEP enabled, mesh size of spherical region = lambda/12 = c0/(12*freq) = 4.2e5m. Sphere is 50mm in diameter, and I am requesting near fields at distance of 1mm along the radius. Which distance and edge length are you talking about?

Share this post


Link to post
Share on other sites

Hi FieldForcer,

I was referring to the length od the edges of the mesh on a surface. At 60 Hz and standard mesh settings, a sphere with 50 mm diameter will be meshed similar to this:

image.thumb.png.90910dfdb0452aed3a84ffff20bceed5.pngimage.png.510ee2783d72b56f0c4275b9a18f4670.png

 

The edges on the surfaces should be around 1 cm in that case which would in principle allow you to request nar field points 1.5 cm from the surface.

 

Please note the mesh size of tetrahedra also depends on the dielectric properties of the medium.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...