Jump to content
Karthic

Energy & Mass error

Recommended Posts

Hi,

I am trying a snap fit in radioss,

I am facing the issue  " RUN KILLED : ENERGY ERROR LIMIT REACHED" and  "RUN KILLED : TOTAL MASS ERROR LIMIT REACHED".

I checked for the Energy plot  , I found steep rise in K.E just before termination.

 

Please guide me to resolve it.

out files attached for reference

 

Thank you

 N.K
 

 

Nozzle cap snap-Explicit_0000.out

Nozzle cap snap-Explicit_0001.out

Share this post


Link to post
Share on other sites

Hi Karthic,

 

this error is common with inapropriate mass scaling, that is when you impose a time step which is too high. Check the mass error due to mass scaling in the .out file: in your model the mass scaling increases the system's mass by 57x. It is suggested to keep the overall mass increase bellow 2% and even then it has to be checked if mass is added to parts that are moving, which would increase the kinetic energy and therefore decrease the simulation accuracy. Short video for energy and timestep error

https://altair-2.wistia.com/medias/osd349gz4k

 

Energy error.pdf

 

Alternatively you could try with advanced mass scaling (AMS) which does not add mass.

 

You can find more information from Introduction to Explicit Analysis using RADIOSS – A Study Guide in Time Step Control chapter. Also recommended is 2017 Radioss user guide starting from page 30.

Share this post


Link to post
Share on other sites

Hi,

 

the reason could be that some elements get severely distorted which is causing excessive penetration. Since you are using hyperelastic material law you should try with hyperelastic property:

property.jpg.5cc64fdc39db7de13f96b55dbaef1630.jpg

 

Try to increase the gap and use the following contact settings for type 7:

Istf=4

Igap=2

Fscale_Gap=0.8

INACTI=6

Gap_min=0.1

Fric = 0.1

Iform=2

 

Also, there is type 11 contact, which is actually causing the error. If it is defined on the same elements as type 7 then the gap should be 0.9x the value of type 7 and if using friction then also use Iform=2.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...