Jump to content
Markus P

Problem with model

Recommended Posts

Hello,

I am trying to do an optimization of one of the booms of a simple crane. I have modeled the crane in a CAD environment and imported it to Inspire. In Inspire I set up the model with pins in the connection between booms, and sliding pins for the hydraulic cylinders. The boom where the design space is has been cut and the connecting surfaces are set to be bonded. I also set up supports at the bottom of the crane, and loads at the end of the last boom. See Figure 1.

Figure 1.

Inspire_forum_fullModel.png

To me, this seems like it should be enough to run analysis and/or optimization. But when I run this model I get an error saying that the model is improperly supported/loaded. What I tried then was to increase the distance used when finding contacts, to set the surfaces where the pins are (the connection between the different booms) to be contacting, see Figure 2. In the CAD environment I intentionally modeled it so they shouldnt be connecting. Using this method I can run the simulation.

Figure 2

Inspire_forum_details.png

This leads me to believe that I am missing something and that the results may be weird...

Am I misunderstanding something when I try to do it like in the first case (Using no contacting surfaces and only pins/sliding pins)? Why does there have to be contacts, why isnt joints enough? Cant forces propagate through a joint?  Do the joints just limit the motion to be relative the common axis of the bodies?

Also, when I run an analysis using the second method (using contacting surfaces and pins/sliding pins) I get result showing that the displacements are over 20 meters, see Figure 3, using no gravity and forces of 1000-2000 N. Which again leads me to believe this is not the right way to model this.

Figure 3

Inspire_forum_displacement.png

I'll upload the .stmod file for the model with included supports and loads. The uploaded model is the model with contacting surfaces which gets displacements of over 20+ m. Any help appreciated!

 

Best regards,
Markus

 

SimpleCrane_straightConfig_designSpace.stmod

Share this post


Link to post
Share on other sites

Markus,

i downloaded your files, running few tests, will send you update asap.

BTW, I would encourage not modeling hydraulic cylinders, instead use forces to represent hydraulic cylinder.

regards,

Jaideep

 

Excavator.png

Share this post


Link to post
Share on other sites

Jaideep,

 

Thanks for your answer. I am going to try the thing with removing the hydraulic cylinders and model it with forces instead.

I have a question about the excavator crane in the figure you provided. In the connections between the booms, where the joints (pins, I guess?) are. What kind of contact surface are used there? Or is it only the pin?

Edit: Or are those connections fasteners?

Edit 2: And how do you find what forces to apply instead of modeling the hydraulic cylinders?

Regards,

Markus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...