Jump to content
yypengpengs

An unhandled win32 exception occurred in WallMan.exe

Recommended Posts

Dear all,

 

When I use WallMan to convert data, I suffer this error every time. I don't know why. I have modified the real debug in Visual Studio and browser, but it still doesn't work. Could anyone help me? I would really appreciate it if you could help me.

 

image.png.91b640d891198a51ac576f62002091d1.png

Share this post


Link to post
Share on other sites

Hi, 

I will need a few more details:

(1) what version of WinProp are you using?

(2) what type of database are you trying to convert? i.e., the extension of the file - is it a .dxf file, .osm file etc..?

(3) I want to confirm that you are indeed trying to convert your database through the API.

Share this post


Link to post
Share on other sites
26 minutes ago, ngoy said:

Hi, 

I will need a few more details:

(1) what version of WinProp are you using?

(2) what type of database are you trying to convert? i.e., the extension of the file - is it a .dxf file, .osm file etc..?

(3) I want to confirm that you are indeed trying to convert your database through the API.

Hi,

Thanks for your reply.

I use the WinProp 2018 student edition.

I tried to convert .osm file download from Openstreetmap to .odb file that can be read by ProMan.

 

Share this post


Link to post
Share on other sites

I can successfully convert .osm files with no problem with version 2018 (student ed.). The problem you have seems to be unrelated to WinProp but more related to the set up you have on your computer (your Visual Studio installation).

Please have a look at the solutions suggested in:

 https://social.msdn.microsoft.com/Forums/en-US/24b356ad-59ef-446f-aa8b-df6b55fa78bb/an-unhandled-win32-exception-occurred?forum=Vsexpressinstall

and 

https://stackoverflow.com/questions/5668338/how-to-disable-visual-studio-debugger

 

 

Share this post


Link to post
Share on other sites
3 hours ago, ngoy said:

I can successfully convert .osm files with no problem with version 2018 (student ed.). The problem you have seems to be unrelated to WinProp but more related to the set up you have on your computer (your Visual Studio installation).

Please have a look at the solutions suggested in:

 https://social.msdn.microsoft.com/Forums/en-US/24b356ad-59ef-446f-aa8b-df6b55fa78bb/an-unhandled-win32-exception-occurred?forum=Vsexpressinstall

and 

https://stackoverflow.com/questions/5668338/how-to-disable-visual-studio-debugger

 

 

I am sorry that the solutions you have mentioned don't work. What should I do.....:(

Share this post


Link to post
Share on other sites

I would suggest the following:

(1) Before converting (With your current version of WinProp), make sure the option to launch the database after conversion is not checked. 

blob.png.eaafcd6c1db4372a7e25d11e801b2469.png

 

(2) Update to a newer version by using feko_launcher.exe -> check for updates and try again

blob.png.1c900cffac170256a9b74e37eda6b77d.png

Share this post


Link to post
Share on other sites
23 hours ago, ngoy said:

I would suggest the following:

(1) Before converting (With your current version of WinProp), make sure the option to launch the database after conversion is not checked. 

blob.png.eaafcd6c1db4372a7e25d11e801b2469.png

 

(2) Update to a newer version by using feko_launcher.exe -> check for updates and try again

blob.png.1c900cffac170256a9b74e37eda6b77d.png

Thank you so much!!! The method (1) works!

Share this post


Link to post
Share on other sites
On 8/30/2018 at 3:12 PM, ngoy said:

I would suggest the following:

(1) Before converting (With your current version of WinProp), make sure the option to launch the database after conversion is not checked. 

blob.png.eaafcd6c1db4372a7e25d11e801b2469.png

 

(2) Update to a newer version by using feko_launcher.exe -> check for updates and try again

blob.png.1c900cffac170256a9b74e37eda6b77d.png

 

It seems like that the 3D scene has some problems. When I open 3D scene, the project crashes and proposes win32 error. 

By the way, where can I purchase the commercial edition of WinProp?

Thank you very much.

Share this post


Link to post
Share on other sites

The observered problems with the 3D view indicate that the DirectX DLLs are not correctly installed.

Typically this should work using the updater, but as you still have problems I would recommend to download and install the required DirectX package from the following link:

https://www.microsoft.com/en-us/download/details.aspx?id=8109
 

For the commercial version please use the contact sheet under the Altair webpage:

https://altairhyperworks.com/ContactUsFormHW.aspx

 

Otherwise please let us know your e-mail address and we will connect you directly with the Altair team in China.

Share this post


Link to post
Share on other sites
On 9/5/2018 at 11:31 AM, reinerh said:

The observered problems with the 3D view indicate that the DirectX DLLs are not correctly installed.

Typically this should work using the updater, but as you still have problems I would recommend to download and install the required DirectX package from the following link:

https://www.microsoft.com/en-us/download/details.aspx?id=8109
 

For the commercial version please use the contact sheet under the Altair webpage:

https://altairhyperworks.com/ContactUsFormHW.aspx

 

Otherwise please let us know your e-mail address and we will connect you directly with the Altair team in China.

 

Thank you for your reply and kindness.

My e-mail address is yuyisun0901@163.com.

Share this post


Link to post
Share on other sites
On 9/5/2018 at 11:31 AM, reinerh said:

The observered problems with the 3D view indicate that the DirectX DLLs are not correctly installed.

Typically this should work using the updater, but as you still have problems I would recommend to download and install the required DirectX package from the following link:

https://www.microsoft.com/en-us/download/details.aspx?id=8109
 

For the commercial version please use the contact sheet under the Altair webpage:

https://altairhyperworks.com/ContactUsFormHW.aspx

 

Otherwise please let us know your e-mail address and we will connect you directly with the Altair team in China.

 

I can open the 3D scene after I install the DirectX.

Thank you for your help!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...