Jump to content
MOHAMED HAMDALLA

wire segment ports in EDIT FEKO

Recommended Posts

Hi all,

I am trying to simulate two wires with loads. I am uploading each wire points from a .txt file. When I am trying to run the file it shows an error that I didn't assign a wire segment ports for the loads. However, they are defined in lines [52-56]. I have attached my editfeko file and wire points files to check if you can help me with this problem. 

Thanks

Done.pre

wire1.txt

wire2.txt

Share this post


Link to post
Share on other sites

Hello,

 

The error is correct. You are creating wires from the points that you read from the text files, but all the wires (built with BL card) have the default label (nl. 0). Later in the script you add three loads and an excitation, but you add it to labels such as "Line6.Wire6.Port2" and they don't exist (all your wire segments are labeled 0). You need label the wires with the LA card and then place the loads and the excitation on the correct label.

 

Everything that you are doing can also be done in CADFEKO (with scripting), but I assume that you have a good reason to use EDITFEKO instead.

MOHAMED HAMDALLA likes this

Share this post


Link to post
Share on other sites

Thank you JIF for your great help. "I don't Know Lua scripting that's why I am using EDITFEKO". I believe if you have documentation for EDITFEKO it will be great for everyone trying to use it.

one last question: how can I define the port of that labeled wire? that is I want to define a wire port at the middle of the wire.

Thanks

Share this post


Link to post
Share on other sites
On 10/3/2018 at 7:55 PM, MOHAMED HAMDALLA said:

I believe if you have documentation for EDITFEKO it will be great for everyone trying to use it.

The manual has an entire chapter on EDITFEKO and the PREFEKO language. The Appendix also describes each "card" in detail. I think all the documentation that you need is already available.

 

On 10/3/2018 at 7:55 PM, MOHAMED HAMDALLA said:

one last question: how can I define the port of that labeled wire? that is I want to define a wire port at the middle of the wire. 

Using EDITFEKO, this will entail breaking up the creating of the wire into three sections (thus, three BL cards). Two of the sections are for the sides and one is for the section in the middle. Ensure that the section in the middle is only one segment long and label it with the LA card. This allows you to then add a source or a load on the segment with that label. For a voltage source, you will then use the A1 source (segment port). If you want to add a vertex source, then only split your wire into two sections and label one of them (at least). Then add the A2 source (with the correct settings) on that label.

 

Take @Torben Voigt's advice and start working with CADFEKO scripting (using Lua). It is much easier than EDITFEKO and you can use macro recording to see how to do some parts (also makes script creation much faster). But be sure to work through the intro section for scripting and the example in the Example guide.

MOHAMED HAMDALLA likes this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...