Jump to content
seyilmaz

Intersection Command Error

Recommended Posts

Hello,

 

I try to create two nodes through intersection of a line and a solid. When the solid lies in the planes XY, XZ or XY there is no problem but when the solid is rotated for example 30 degrees then only one node is created. I tried to explain with pictures. Do you know how to solve the problem?

 

Regards,

 

 

2124483426_Gorsel3.png.b2efdc12ea0ace61d8579d4dfa80306b.pngGorsel.png.09e0a85a60660d849967734acd9adc75.png

Share this post


Link to post
Share on other sites

Hello Premanand,

 

Thank you for your answer, but when I tried from different view angles still 1 node created only. 

 

On the other hand, I am working on a script so the viewing direction does not really matter for me.

 

Thank you

Share this post


Link to post
Share on other sites

I use the following commands to search for interactions for each surface but this gives and error when I call from a tcl file.

 

*createmark surfs 1 "all"
set surflist [hm_getmark surfs 1]
foreach surfid $surflist {
*createmark lines 1 1
eval *createmark surfs 2 $surfid
*nodecreateatintersection lines 1 surfaces 2 0

}

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...