Jump to content
zhoutaozju

Error Code:9; Feature not Found

Recommended Posts

Hello,

   My WinProp is equipped by student edition license. Recently, I tried to run the sample project of WinProp which is located in "..\Altair\2018-edu\feko\api\winprop\compiler.cpp".   Unfortunately, it seems there is some thing wrong with my licence (as is shown in the following figure).

 

image.png.dc70602e1016268be18a5d3ae9865d17.png

 

I am able to run WinProp in user interface normally which indicates the correctness of my license. I did check my Ethernet ID which was the same as that in my licence. And I am sure the filename of my license is "altair_lic.dat" rather than "altair_lic.dat.dat".

 

I also tried it on my friend's computer which is equipped by a student edition license, too. Similarly, his user interface worked normally but he met the same error as mine when running the sample program of WinProp API.

 

I notice that the alert claims that some necessary features are missing in my license. And I didn't find those features in my license indeed . So I think maybe it is the matter of my license edition rather than the matter of my Ethernet ID. Shall I upgrade my license?

 

By the way, my platform is VS2015. Shall I do any configuration before running the program?

 

 

Thanks for your help!

 

 

 

Regards.

Share this post


Link to post
Share on other sites

It is indeed a limitation of your license. The student license enables you to run WinProp through the Graphical User Interface (GUI), but not through the API. To run WinProp through the API, a regular license is needed.

Share this post


Link to post
Share on other sites

×
×
  • Create New...