Jump to content
sbalazs

enforced displacemnt in a local csys with NLGEOM - possible bug

Recommended Posts

Hi,

 

I tried to model the pretension for a NLGEOM analysis with enforced displacements in a local csys. If the pretension is not followed by an another loadcase, the results are OK, if there is a follower loadcase the results are not the same as before and wrong.

 

Attached you can find a test model (with pretension with and without an additional loadstep). Nodes id. 1 and 2 are the ones with enforced displacements in the local csys id 4. Please take a look at the displacements for the pretension in both cases.

 

Is this problem known? Is there a workaround for this problem?

 

Thank you.

 

Best regards,

Szilard Balazs

 

 

example_NLGEOM_pretens_load.zip

comparison.png

Share this post


Link to post
Share on other sites

Can you try this in the latest version OptiStruct 2018.0.Lot of new feature has been changed since version 14.0.We now solve Nlgeom with large displacement analysis.

Please request free eBook on OptiStruct Nonlinear analysis with below link.

https://altairuniversity.com/free-ebook-introduction-to-nonlinear-finite-element-analysis-using-optistruct/

Share this post


Link to post
Share on other sites

Hi,

 

thanks for your answer, I tried to solve with Optistruct 2017, unfortunately occours the same problem....We don't use Optistruct 2018 at the moment.

 

Regards,

Szilard

Share this post


Link to post
Share on other sites

Hi Rahoul,

 

here are the results when I run the same input files under Optistruct 2017.

 

My problem is that the same pretension lodcase (enforced displacements in a local csys) produces different results whether there is a follower loadcase or not.....

 

Regards,

Szilard

comparison_opti2017.png

Share this post


Link to post
Share on other sites

Hi,

 

I used the same fem file which I used for the Optistruct 14 run (see atached files from my first post), I only used the Optistruct 2017 solver (since I want to do the same analysis ) .... Is it wrong doing so ?

 

Regards,

Szilard

 

Share this post


Link to post
Share on other sites

Hi Rahoul,

 

did you find out something about this Optistruct bug? Is there really no solution for this problem? How can I perform this analysis in an another way?

 

Regards,

Szilard Balazs

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...