Jump to content
eschlieper

SparkFun RedBoard

Recommended Posts

I'm wondering if anybody has had any luck getting the SparkFun RedBoard to work with the Embed product?  I've been able to successfully compile and download to an Arduino Uno that I have but have not been able to download to the RedBoard.  I get an error: Can't open Com0.  Check that the Serial Monitor is closed.  I'm trying to use the blinking light test for both of these.  Any insight would be appreciated.

Erich

Share this post


Link to post
Share on other sites

Dear Erich, 

 

Could you please post in the issue that you see as a snapshot ?

Could you also double click on the Target Config block and let us know if the auto detect utility recognizes the redboard and the corresponding comport ?

 

Thanks,

--sreeram

Share this post


Link to post
Share on other sites

I will do that.  It has taken me a while because I forgot to check the notify me of replies.  I'll see what I can do in the next day or two.  Thank you for responding.

Erich

Share this post


Link to post
Share on other sites

Ok, I've had a chance to sit down and find the things you were asking for.  In case there was something with the FTDI driver creating the COM port, I updated that and still get the same issue.

 

It does appear that the redboard is not being auto detected.  I don't see anything in the COM port selection when editing the Arduino Config..

 

Attached is a picture of what I see there and the screen shot of the COM0 dialog.  I hope that helps.  I'm happy to show you anything else you need to see as well.

1045271177_COM0Message.JPG.56aa2bdcc763226a7eccbc3acffff318.JPG1453547569_ArduinoConfig.JPG.7d95c346a58c8ebfd3362b0b62664474.JPG

Share this post


Link to post
Share on other sites

Hi, 

 

As a workaround please follow the below steps and I hope you should be able to get the hex file downloaded from Embed on the redboard that you have. 

 

1) Navigate to the directory where Embed is installed. The default location is C:\Altair\Embed2019\cg

2)  Look for a file called downloadToArduino.bat and back up and make a copy so that you can revert in case there are issues modifying it. 

3) Open the above batch file in a text editor like notepad and in line number 3 you would see 

     set COMNUM=%2 

4) Edit the above line to replace %2 with the comport number of your board for example if your redboard comport number is COM12 then

     set COMNUM=12

5) Save the file and now when you generate code from Embed and then try to download the hex file you should be able to get the hex file onto the target. 

 

Please let me know if you need further help with this 

 

--sreeram 

 

 

Share this post


Link to post
Share on other sites

Thank you Sreeram,

 

I'll give that a try and see if it works.  I'm going to assume then that if I've been using another board that wasn't having this issue that I'll have to switch between the two files or COM ports to when I move between the two boards.  That is manageable for me, I just wanted to make sure that is what needs to happen.

 

Regards,

Erich

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×