Jump to content

Recommended Posts

Hello,

I just got into Altair Embed and I have encountered a problem. Whenever I try to download the already generated and compiled code into my Launchxl-F28069M it sais "Target open failed: check config for correct target number". I will post a picture below with my config and model. Even a little hint would be appreciated! Oh and also, I need to mention that I have all SW1 set to ON to enable JTAG comms.

Thanks in advance for everything!

 

Quick edit: I just tried to run this model in interactive mode, and got an error that said something about there being no JTAG communication. How can I make sure I have a solid communication? (via USB). The error was: Can't open target. Check: 1. Power to target 2. JTAG connection 3.JTAG driver selection in target config

1.JPG

2.JPG

Share this post


Link to post
Share on other sites

Hi Tudormasalar, 

   This issue was either due to F28069m driver issue (Install proper drivers) or the SW1 for Jtag connection should be in ON condition (all three).

Check the above methods, it will work.

Regards

Athieshkumar T

Share this post


Link to post
Share on other sites

Hey Tudormasalar,

 

Did you find solution to your problem? Even we encountered the same error.

There are ideally two drivers which are in visible in the device manager of PC, 1) XDS100 Class Auxiliary Port, 2) XDS100 Class Debug Port. The second driver is not visible in my PC.

Did you face the same issue? if your problem was solved, please tell me the solution.

 

Regards.

Share this post


Link to post
Share on other sites

Hey Tudormasalar,

 

Was your problem resolved? We have encountered the same issue i.e. the code gen download error(Target Open Failed).

There are ideally two drivers in the Device manager of your PC. 

1) XDS100 Class Auxiliary Port

2) XDS100 Class Debug Port

The second one is not visible in my PC. was your problem the same? If your problem was solved, then please tell me how you did it.

 

Regards.

Share this post


Link to post
Share on other sites

Hi Gaurav, 

 

Can you please provide the following info: 

1) What is the embed version you are using ?

2) What board in pacrticular?

 

With the latest Embed versions we ship the necessary Ti compilers and we have not seen issues. Could you provide more info. 

 

--sreeram

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...