Jump to content

Recommended Posts

Dear friends,

 

Good morning, I am solving a modelo and when I run it I have this message:

 

"

*** ERROR # 153 ***
 Exactly zero pivoting encountered during Numerical Factorization;
 the model may have rigid body mode.
  Solver error no. =   -514 
        spc set id = 1 
             index =      1 
 Possible reasons are:
 1) insufficiently constrained model,
 2) having rigid body mechanisms within the model,
 3) extremely ill-conditioned rigid element sets,
 4) extremely thin shells (as used for skinning) that have MID2/MID3,
 5) gap elements with extremely high stiffness (KA, especially KT or MU).
 6) extremely high Poisson's ratio in hyperelasticity material definition.
 Check the model and rerun the problem.
 (MECHCHECK may be used to find the rigid body modes.  To do so,
  change the input to be an eigenvalue analysis and add MECHCHECK.)
 (WARNING: results obtained with MECHCHECK cannot be used because
          the model is changed internally.) This error was detected in subroutine bcsmtxfct.

 

I can't find the way to define the MECHCHECK option (anybody could please share a detailed tutorial of it? Because I define an EIGENVALUE analysis but then I don¿t kno how to define the MECHCHECK option. 

 

Thank you very much for your attention. Best regards.

"

Share this post


Link to post
Share on other sites

Dear Rahul,

Thank you very much for your reply, it has been useful to me. I have two more questions: when I run considering that control card, I've got this result:

Iteration Subcase     Variable  Grid/Elem ID   Value
---------------------------------------------------------
    0      1 MaxDisp                 40574_X  6.5587e+12

 

What I can understand is that the Element ID 40574 is not constrained. How is it possible to find it? I try to mask it but I can't.

 

Once that I have defined that Control Card, how I can disable it?

 

Regards,

 

JJJ

Share this post


Link to post
Share on other sites

 

Mask element by id:Reverse: Fit to screen: Add nodes on that element: find attached the adjacent element

Disable option is available in the control card section.

Disable MECHCHECK.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...