Jump to content
lostarmour

ERROR 33238: Not enough memory available on the hard disk for an out-of-core file

Recommended Posts

When I run my model with the default solver (I guess it is MOM), I get an error which says "ERROR 33238: Not enough memory available on the hard disk for an out-of-core file" though I already have 8 GB  of RAM and more than 200 GB of free HDD space. However, when I switch to FDTD solver, it doesn't show up the error, but it takes a really really long time. I have attached the model to this post. Please help me what to do with this error as I haven't found any good solutions yet.

08262019_Feko_two_blades.fek

Share this post


Link to post
Share on other sites
16 minutes ago, mel said:

Hi Lostarmour

 

Have you tried MLFMM?

I just tired that and I have another memory related error. ERROR 32476: Not enough memory available for dynamic allocation 

Share this post


Link to post
Share on other sites

You can use the default solver but with "Coarse" meshing - this is more than sufficient for plane wave incidence. Also set the mesh growth factor (mesh, advanced tab) a bit coarser since there are some very fine detail.

Share this post


Link to post
Share on other sites
30 minutes ago, mel said:

You can use the default solver but with "Coarse" meshing - this is more than sufficient for plane wave incidence. Also set the mesh growth factor (mesh, advanced tab) a bit coarser since there are some very fine detail.

With coarse meshing, I always run into mesh error like this. I am not sure how to get rid of these and I get these all the time.

ERROR 40619: Intersecting triangles found

See also message in the output file 08262019_Feko_two_blades_V2.out

Share this post


Link to post
Share on other sites

The model contains very fine geometry, and usually there are tolerance issues with imported geometry.

You could consider to remove it, else refine the mesh, but this will then again increase the resources.

On the Mesh tab, unlink the mesh and use "Find intersecting triangles". This will give the labels with problems.

With opacity and a cutplane you can view them. Or in POSTFEKO enter the triangle numbers (given in the ASCII OUT file) under "Find elements" on the Mesh tab in POSTFEKO to find them as well.

 

unlinked_mesh_find_intersecting_trias.png

Share this post


Link to post
Share on other sites

I removed the intersecting triangles but how can I link the same mesh back? I can only see an option which says "Use model mesh", which is I think doesn't do exactly what I want. How can I re-link it with the Geometry?

Share this post


Link to post
Share on other sites

Hi @lostarmour,

 

You should make all regions PEC and then use "Simplify". This deletes 24 (small) redundant faces:

image.thumb.png.24f1e2de68d80b4ae68fdfa60e8b45b2.pngimg_057.png.2def504f26ca9a92784beec7d487a190.png

 

 

 

 

 

 

 

 

 

Then I found out that these areas are the tricky parts:


img_060.png.2131db4714bb816544205faf955b2df6.png        img_061.png.8565b0dd9cefc5940aedc83714896ef8.pngimg_059.png.43d6aa2e41dc730f008af4811ae9881b.png

I closed these two and now it works 9,072 triangles (compared to 51,554 in the original model): 08262019_Feko_two_blades_alt.cfx

 

It solves in a couple of minutes. Please make sure to refine the mesh slightly and compare the results. This is just an example.

Share this post


Link to post
Share on other sites
On 9/5/2019 at 8:50 AM, Torben Voigt said:

Hi @lostarmour,

 

You should make all regions PEC and then use "Simplify". This deletes 24 (small) redundant faces:

image.thumb.png.24f1e2de68d80b4ae68fdfa60e8b45b2.pngimg_057.png.2def504f26ca9a92784beec7d487a190.png

 

 

 

 

 

 

 

 

 

Then I found out that these areas are the tricky parts:


img_060.png.2131db4714bb816544205faf955b2df6.png        img_061.png.8565b0dd9cefc5940aedc83714896ef8.pngimg_059.png.43d6aa2e41dc730f008af4811ae9881b.png

I closed these two and now it works 9,072 triangles (compared to 51,554 in the original model): 08262019_Feko_two_blades_alt.cfx

 

It solves in a couple of minutes. Please make sure to refine the mesh slightly and compare the results. This is just an example.

I Still get the error after simplifying. I made them all of one material and then applied the simplify. Then, as you said it removed 24 redundant elements and I ran it and still I ran into memory issues. I am even doing it on a cluster. And I couldn't use your file because it is built on 2019 version and I am using a 2018 version. Please help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...