Jump to content
Imre.F

Composite modeling in HyperMesh

Recommended Posts

Dear forum members!

 

I am new member of Altair community and I am trying to model composite laminate. I created some plies with difference patches and the visualization of the different layers made me little anxious.

 

You can see the mentioned composite layers on the attached images. The plies are symmetric in the laminate nonetheless the 3D visualization of the composite showed differences between the upper and the lower side of the composite plate. I am afraid that this kind of modeling will lead poor results.

I tried to change the type of the laminate from stack to symmetric but the result was the same.

 

How can I model the composite properly if I want to "mirror" the top half of the composite plate to the mid-plane?

Somewhere I read about sub-laminates but at first look seemed complicated. I would be happy if I could solve this modeling problem easier.

 

Thanks your answers in advance!

 

Have a nice day!

Imre.F

composite_01.PNG

composite_02.PNG

Share this post


Link to post
Share on other sites

Hey tinh!

 

It does not help. The result is the same even if I change Z0 options to Bottom/top/real (and I write in a z0 value). The visualization of the real and the bottom options is like each other's reflection.

Share this post


Link to post
Share on other sites
13 hours ago, Imre.F said:

Hey tinh!

 

It does not help. The result is the same even if I change Z0 options to Bottom/top/real (and I write in a z0 value). The visualization of the real and the bottom options is like each other's reflection.

 

Vizualization is not important. If you set ZOFF solver will 'understand' and compute with the value. Sometimes hm visualizes problems.

Share this post


Link to post
Share on other sites

I share the file with you. You can see that the plies are symmetric (colour of the plies is the same in both side of the composite).

 

I think the problem is that I created the plies on a surface and the laminate option "lay up" these plies/patches on this surface. In this case the visualization shows the stack just right.

However, the model is attached, if you have time please take a minute to look into it.

 

Thanks your help, btw!

composite_laminate.hm

Share this post


Link to post
Share on other sites

Hey Hyperman!

 

Thanks for your effort, you understand me well.

I was lame and did not leave the z0 offset blank, I left there a 0 mm value.

 

Thanks again, you are the real hero, not superman. :)

 

 

 

Hyperman and Rahul R like this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...