Jump to content
goto

グラフィックス領域に形状が表示されない

Recommended Posts

    
HyperMesh2017,2019で発生。HyperMesh14では正常に動作。

環境は Windows10 Pro, Intel Xeon E5-1620 v2, メモリ64GB, Quadro k2000 ドライバ 411.95

 

メニュー等のインターフェースは表示されている。

グラフィックス領域の背景色はデフォルトのグラデーションが描画されている。

グラフィックスエリアのタイトルは複数のフォントで描画されているのか、読み取りは困難な文字列。

座標軸形状は矢印は描画されず、X,Y,Zの文字が回転等のマウス操作によって残像を残すように描画される。

形状はGeometry,Elements,座標軸形状の矢印,Nodesで作成する点の全てが描画されない。

 

サンプルデータ"C:\Program Files\Altair\2019\demos\hm\simple.hm"を開いた場合、

countのFE  entitiesのallにてnodes=28,elems=16,comps=5と表示されていることからElementsが存在はしていると考えられる。

 

以下を適用したが改善は見られなかった。

https://forum.altair.com/topic/21770-hypermeshの動作や表示がおかしい場合/

 

環境等の設定で改善の可能性がある方法を教えてください。

 

 

open_simplehm.png

Share this post


Link to post
Share on other sites

ご提案ありがとうございます。

残念ながら最新グラフィックドライバーを適用しましたが状態は変わりませんでした。

HyperMesh14に戻して対応いたします。

HyperMesh2019とのデータ共有をできないことが厳しいです。

Share this post


Link to post
Share on other sites

何らかの問題で、グラフィックボード性能が正しく使えていない可能性も考えられますので、

プルダウンメニュー「Help」⇒「Update and System Information」の「System Information」タブの情報を共有して下さい。

System.jpg

Share this post


Link to post
Share on other sites

お手数をおかけいたします。

 


 System Information:
------------------------------------------------------------
Machine:                      amd64
OS:                           windows Windows NT 6.2
User:                         goto

 Graphics/Display/OpenGL:
---------------------------
Name:                         NVIDIA Quadro K2000
VideoProcessor:               Quadro K2000
AdapterRAM:                   2 GB
DriverVersion:                26.21.14.3194
DriverDate:                   20190919000000.000000-000
CurrentBitsPerPixel:          32
VideoModeDescription:         1920 x 1080 x 4294967296 colors


よろしくお願いいたします。

Share this post


Link to post
Share on other sites

@goto ありがとうございます。

 

動作環境に不自然な部分があります。

OSの項目が、『Windows NT 6.2』となっていますが、『Windows NT 6.2』=『Windows 8』もしくは『Windows Server 2012』の何れかという事になります。

※HyperWorks2019では、Windows系のサポート環境を、『Windows 7』もしくは『Windows 10』とさせていただいています。

 

『Windows 10 Pro』をお使いとのことでしたが、『Windows NT 6.2』となる原因などについて思い当たる点などはないでしょうか?

Share this post


Link to post
Share on other sites

思い当たる点は無いのですが、マシン情報を添付画像にてお送りいたします。

よろしくお願いいたします。

当該マシンの情報.png

winver.png

Share this post


Link to post
Share on other sites

リモートツールなどを介して利用されていないでしょうか?

もし、リモートで問題がある場合は、直接そのPCで試してみて下さい。

Share this post


Link to post
Share on other sites

勘違いしおりました、失礼しました。OSの項目はNT 6.2で問題ありません。

System InformationのOperating Systemの項目は、Windows 10が表示されているという理解で問題ないでしょうか?

 

Windowsのログイン時に、他の方のユーザーIDでログインした場合も、同様の現象が起きるか試してみていただけないでしょうか。

Share this post


Link to post
Share on other sites

大変お手数をおかけいたします。

別アカウントを作成しHMを起動しました。状況は変わらないようです。

画像を添付いたします。

別アカウントを作成しHMを起動.png

Share this post


Link to post
Share on other sites

考えられる方法をいくつか記述してみます。

 

1.再度「https://forum.altair.com/topic/21770-hypermesh」からダウンロード可能なバッチファイルを実行しておく。

bat.jpg


2.HyperMesh起動後に、プルダウンメニュー「Preferences」⇒「Mesh/Geom Appearance」のAnti-aliasingタブのチェックを外してみる。

Anti.jpg

 

3.HyperMesh単品版ではなく、「HyperMesh Desktop」側で起動してみる。

Desktop.jpg

 

4.Windowsのデスクトップで右クリック⇒NVIDIAコントロールパネルの設定を変更してみる。

NVIDIAコントロール.jpg


5.HyperWorks2019で追加された、「HyperWorks X」で起動してみる。
HWx.jpg

 

Share this post


Link to post
Share on other sites

ありがとうございます。

 2.Anti-aliasingタブのチェックを外す

にて、正常な描画が出来るようになりました。

HyperMesh, HyperMesh Desktopにて確認しました。

 

また、HyperWorks Xについてはこれまで言及していなかったのですが、

上記Anti-aliasingタブのチェックを外すまでは残像が多く残り操作が困難な状態でした。

こちらも正常に描画されました。

Anti-aliasing設定は共通で使われているのでしょうか?

 

大変お手数をおかけいたします。

ありがとうございました。

Share this post


Link to post
Share on other sites

良かったです:)

NVIDIAコントロールパネルの「プレビューによるイメージ設定の調節」で、デフォルトの「3Dアプリケーションによって自動的に決定する」にしておくと、HyperMeshでAnti-aliasingのチェックを外さなくても問題なく動作するかもしれません。

Nvidiaコントロール.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...