Jump to content

Recommended Posts

Hello all,

 

I am creating a beam element connected between two nodal rigid bodies with the line 

*createspotweld $x $y 0 0 0 0 0 ""

 

Where x and y are the independent nodes of 1st and 2nd NRB respectively. When I look into file for generated beam element in the *ELEMENT_BEAM card (LS-Dyna), the 3rd node for the beam element is assigned with a random node id (but same coordinates as first node). Is there any possibility to replace the 3rd node id with the 1st node id? 

Share this post


Link to post
Share on other sites

Hello @Ushay

 

I think you can create beam with "*barelementcreatewithoffsets" command.

 

*createvector 1 1 0 0
*barelementcreatewithoffsets Node1 Node2 1 Node3 1 0 0 "" 0 0 0 0 0 0 0 0

 

Thanks,

Imoto

Share this post


Link to post
Share on other sites
On 10/21/2019 at 10:35 AM, Imoto said:

Hello @Ushay

 

I think you can create beam with "*barelementcreatewithoffsets" command.

 

*createvector 1 1 0 0
*barelementcreatewithoffsets Node1 Node2 1 Node3 1 0 0 "" 0 0 0 0 0 0 0 0

 

Thanks,

Imoto

 

Hello @Imoto,

 

thanks for the reply. 

 

It is not accepting the Node 1 and Node 3 to be the same. 

 

 image.png.844127c6cc6a483ad8f699c6b74d581c.png

 

I am trying to make the nodes 1 and 3 the same, to get something like this for a beam element.

 

image.png.53d099e3ecc4d58bb3256604a885fd18.png

 

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...