Jump to content
zoltaaaan

Hypermesh, Include Files and Export for LS-Dyna

Recommended Posts

Hey everyone,

I ran in some problems again and wanted to know, if there are easy fixes that prevent me from adding too many manual changes to my include keyfiles.

 

In Hypermesh, I set up a model for LS-Dyna with a tree structure of include files. Some include files are positioned with the Transformation Manager (*INCLUDE_TRANSFORM).

I have two issues at the moment:

 

1) Remove Transformation

I imported a model as an include and then added a transformation to it. The include type changed from 'Include' to 'Include_Transform', that worked fine. After some more changes, I wanted to change the type back to 'Include'. I deleted the transformation in Transformation Manager, but the type is still 'Include_Transform' now I have the issue that upon export, there is no '*INCLUDE' or '*INCLUDE_TRANSFORM' keyword written in the keyfile.

How can I change the include type back?

 

2) Prevent export

I have an include file, which is structured in another include file (e.g. in my master file it says '*INCLUDE file_a' and in file A it says '*INCLUDE file_b'.

Now I unchecked the export box in the model browser for file B, because I do not want it right now. File B is rightly not exported, but in file A it still says '*INCLUDE file_b', which gives me an error message, since file B does not exist.

How can I prevent this error from happening?

Edit: I found a solution. Simply check a box at 'Remove include file reference based on export status' which you can find under Export Browser > Solver Options.

 

Thank you in advance :)

Share this post


Link to post
Share on other sites

Which version of HyperMesh you are using?

HyperMesh 2019.1 for LS Dyna interface has new feature of transformation entity. Please share screenshot of the error you get for query 2.

 

Dyna Include transform.JPG

Share this post


Link to post
Share on other sites

Hi Rahul, thank you for your reply.

 

My HM version is 2017.2 with user profile LS-Dyna Keyword 971_R8.0.

 

What do you mean by query 2? I do not have error messages in hypermesh. It exports without error messages. The result from issue #1 is that there is an *INCLUDE keyword missing and the result from issue #2 is that there is an *INCLUDE keyword for a non-existant include file.

 

The only error message I get is from LS-Dyna solver and it says it could not find the include. This is the result from issue #2 and makes sense.

 

My questions focus on the export from hypermesh, where those two issues happen without error message.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...