Jump to content

NLADAPT DIRECT=yes is not used in my case ?

Recommended Posts


    I need to fix time increment in my load step , have set NLADAPT>DIRECT>YES,and referece this load  in my loadstep. But the solver seems to ignore it and keeps increasing the incerement size.Can somebody give me an advice on what I could do to solve this issue? Thank you very much!


Share this post

Link to post
Share on other sites
On 10/24/2019 at 6:46 AM, young said:

hi cfuser,my NLparm entry likes this, image.png.1697760998fff3026b70f7672f1026b2.png



Hi Young, 


It's weird. I ran a non linear static simulation (frictional contact model). I used this configuration (for NLADAPT,  NLOUT and NLPARM respectively)



and It worked well ...


If it's not confidential, can you please share your model or verify the time increment story in simple model than you can share it ?


Best regards, 

Edited by Farouk Maaboudallah
Tabulation problem

Share this post

Link to post
Share on other sites
On 10/26/2019 at 3:27 AM, Farouk Maaboudallah said:

To be sure : I repeated the same simulation. Instead of using 0.1 I used 0.05 and it worked well ... 




Please keep me in touch.


    Thank you for your reply, I tried the configuration as you said, but it  not works very well,still keeps increasing the incerement size.I try a simple case likes this:


Share this post

Link to post
Share on other sites
1 hour ago, Hyperman said:



Increment adjustment is automatic by default PARAM>EXPERTNL>AUTO. Try with PARAM>EXPERTNL>NO instead.


       I have tried this setting as you said,it worked well, the increment size is fixed.Thank you very much.

     But, in other case ,I haven't keep expernel>no, just be sure the DTmax equals to DTmin, the increment can be fixed, so 8s this setting( PARAM>EXPERTNL>NO) only necessary in some cases? 

       Looking forward your reply.


Share this post

Link to post
Share on other sites
12 hours ago, Hyperman said:

The increment can be fixed using either:

  • DTmax=DTmin 

However NLADAPT>DIRECT>YES does not work for some reason. 

Thank you very much.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...