Jump to content
tlc

WinProp ProMan simulation errors

Recommended Posts

Hi,


I am using WinProp ProMan in the Feko + WinProp 2019.2 Student Edition package with node-locked local license and I get the following two errors:

 

1. If the application is run immediately at system start, it correctly computes simulations but, after 5-10 minutes, it reports the following error when simulations are run:

 

license_error_1.png.266db8f80008b8c54281ff4104d1af56.pnglicense_error_2.png.0584cdd23851d6d2b50118d762069ff1.pnglicense_error_3.png.e2204426ec77e39dbc36a8b6f3188b17.png

 

2. The computation of some sites appears as completed in the computation log window but it is not carried out, and the number of skipped sites varies according to the "Nr of concurrent computations" specified in the computation global settings:

 

skipped_computations_error.thumb.png.d8b28d3be43b86d47cc4441d12d1b8ed.png

 

I am running WinProp ProMan on Windows 10 Pro.
Has anyone else encountered and solved the same errors or can help me?


Thank you.

Share this post


Link to post
Share on other sites

The WinProp Student Edition has a few built-in limitations. Those are listed here:

https://altairuniversity.com/feko-student-edition/

One limitation is the number of transmitting antennas.

 

I don't know what might cause the licensing problem. You say it occurs (only?) immediately after system start. Possibly the license server, along with many other programs on the PC, needs time to get loaded and started after you turn on the PC.

Share this post


Link to post
Share on other sites

Hi mvogel,


Thank you for your answer.


I checked that the number of transmitting antennas is below 12, as for the limitations in an urban scenario, and I tried to change the number of antennas, but the computation issue remains the same.


For the licensing problem, the behaviour I was trying to describe is the opposite: the application runs correctly the simulations at system start but, after a while, it returns the license error when trying to run any other simulation for the remaining time during which the system is on. Moreover, my license is a node-locked local license and I do not use any license server.


The licensing problem is the most limiting one (since I cannot run simulations for more than 10 minutes from system start).


Can you suggest me any procedure to solve this issue?


Thanks

Share this post


Link to post
Share on other sites

The best I can do is copy and paste text from a software-installation expert.

 

"Once you receive an altair license file and tried to use it, however you get a license error

 

1) You need to ascertain - Is this a standalone (node locked) license file or do you have a server license,

To identify if your license file is a server based license or a standalone license, please open the license file in a text editor

The difference between a server based license and a node locked license is that in a server based license each feature has a COUNT field.

 

2) If it is a node locked license, all you need to do is place it in the security folder as you have, in which case, you must check if the Ethernet ID is correct as per below (please delete/uninstall the license manager in this case)

 

also please take care and check for the file extension, i.e. it should be *.dat and not *.dat.dat (this could resolve the issue)

 

Again when you open the license file in a text editor you will see an Ethernet address there in a line that says "ETHERNET =

The Ethernet ID is the id of your machine which is exactly 12 hexadecimal numbers. For example D4WRF478F398

Please check your computer’s Ethernet address, by using the almutil -hostid application from the Start > Altair > Tools > Admin tools Menu
The listed Host ID should be used to generate the license file.

You can also find it by running ipconfig/all in command window and check for physical address under Ethernet adapter local area connection:

Alternatively run getmac in command window to find out available Ethernet addresses

 

3) If it is a server based license, follow the procedure in the attached video to install and use the license manager in the machine whose Ethernet ID is in the license file,

 

4) If you have a license server running (and if you know the hostname of this license server machine) you need to connect to this server machine by setting an environment variable in your machine,

Please set an environment variable to connect to the license server machine as below if using Windows 7

Windows 7

 

1. Right click on My Computer from the Start menu

 

2. Choose Properties from the context menu

 

3. Click Advanced system settings > Advanced tab

 

4. Click on Environment Variables,

 

5. Click on new under the system variables section and enter the variable name and value

 

The proper format for a network license location is port@hostname

ALTAIR_LICENSE_PATH port@hostname

port is the port number. The port number in this command matches with the port number in the TCP_LISTEN_PORT = 6200 line in the altair-serv.cfg file in the licensing folder, changing this port number in the altair-serv.cfg file will allow you to connect using this new port and the environment variables will then need to be set with this new port number.

host1 is the host name, this can be the name or the IP address of the servers."

 

Note that there are two different types of licenses, with and without the word "count" in it. The best is to work with a license file without the word "count": just give it the correct name and place it in the correct directory. If your license has the word "count" in it then things get complicated. You'd need to download and install additional software (a license manager) and set up things such that WinProp communicates with it through a "port", even if everything takes place within one machine.

 

Share this post


Link to post
Share on other sites

Hi mvogel,


Thank you for the recommendations.


I confirm that my license is standalone (node-locked, without the word "count" in it). I checked the license troubleshooting instructions and all the license settings had already been correctly set.


I would like to report that the described license issue emerges only into the ProMan software. All the other software into the Feko + WinProp 2019 Student Edition package is working correctly and not reporting any license issue.


Is there some debug option that I can enable into ProMan in order to determine what is the cause of the error?


Thanks

Share this post


Link to post
Share on other sites

Hi, 

I'm having the license error as well. 

My license is node-locked (standalone)  without the word "count". I have also tried the troubleshooting procedures and still having the error.

 

Can you suggest me any other procedure ?

Share this post


Link to post
Share on other sites

Hi Dujaya,


a new update for the Feko + WinProp package has just been published. In my case, it seems to have solved the license problem, but I am still experiencing the error on the skipped computations.


I hope it will solve your license issue too.

Share this post


Link to post
Share on other sites

×
×
  • Create New...