Jump to content
ezzymn

HyperMesh 2019 Assembly View

Recommended Posts

Hi all, 

 

After upgrading from 2017 to 2019, I've noticed that in the standard model browser window under "Model View", you can see any assemblies but they do not expand in that pane. Instead you need to double click or go to "Assemblies view". 

 

The only issue with this, is that the "Assemblies View" only contains components and not groups etc. 

 

Is there a setting to behave like 2017 and allow the assemblies in "Model View" to expand?

 

Many Thanks

 

2019 - "Model View" Unexpandable

Capture.PNG

 

2017 "Model View" - Expandable

Capture_3.PNG

 

2019 "Assemblies View" - No Groups or Properties etc

Capture_2.PNG

Share this post


Link to post
Share on other sites

That's the configuration browser isn't it? 

So that allows me to see / hide assemblies within the model view, but not the ability to expand assemblies within the model view

Share this post


Link to post
Share on other sites

Hey Tinh, 

 

Tried that, and it doesn't do as we want I'm afraid. 

 

Another little thing I've just noticed. Everytime you go to the "Assembly Viewer", it switches the mesh view to "By Assem", which is rather annoying...

Share this post


Link to post
Share on other sites

Hi

When you enter the dialog "browser cinfiguration", did you see any check box named "Assembly Hierarchy"?

Or you just see "Assembly"?

 

 

Sorry to ask too detail because I don't have hm2019.

Share this post


Link to post
Share on other sites

Hi Rahul, 

 

Thank you for the video, I learnt things that I wasn't expecting.

 

But the problem still stands - I can't open the part browser in the other side, as we have our utility menu there. 
The Assemblies don't expand in the Model Browser

The Part Assemblies don't expand in the Model Browser. 

 

The solution of opening another view on the right task bar just won't work for what we do. 

 

@tinh - Enitities - Assemblies

Share this post


Link to post
Share on other sites

Hi @ezzymn,

 

You can disable auto color by entity type in the Browser Configuration dialog.  Uncheck "Autocolor visualization mode" under Local Options.

 

It is worth noting that Assembly View of Model browser shows only Assemblies and Components, so it is not possible to interact with entities such as Groups, Properties and Materials.  In Part browser, dedicated columns show you the Component, Property and Material associated with the Part.  See the image below:

 

image.thumb.png.540bd5c88dc6ce5841c115e38966cc74.png

 

Since Parts may not be relevant to your workflow, feel free to contact me via DM so I can learn more about your use case and offer additional assistance. 

 

Cheers,

 

Joe

Rahul R likes this

Share this post


Link to post
Share on other sites
10 hours ago, ezzymn said:

 

 

@tinh - Enitities - Assemblies

 

I thought so.

Could you please open command window (menu Views>command window) and then enter below command:

 

set ::env(HMBR_CONTENT_HIDE_ASSEMBLYHIERARCHY_FOLDER)

 

and then take a screenshot?

I want to see the settings on hm2019

 

Share this post


Link to post
Share on other sites

Hi @ezzymn

I seem to find out where the settings can be customized.

It's exactly stored in below files:

<install dir>/hm/scripts/br/views/model/regular/

 

Please copy the folder 'regular' and zip it then post it here. I will modify settings and send back to you.

 

Don't modify it by yourself because it's easy to be fault.

Share this post


Link to post
Share on other sites

Hi @tinh

 

set ::env(HMBR_CONTENT_HIDE_ASSEMBLYHIERARCHY_FOLDER)

can't read "::env(HMBR_CONTENT_HIDE_ASSEMBLYHIERARCHY_FOLDER)": no such variable

 

I feel like the functionality might be removed, but I appreciate you having a look. I've tried the crude attempt to copy over the 2017 files, but that segmentation faulted. 

 

Reports.7z

 

Many Thanks

Eric 

Share this post


Link to post
Share on other sites

@ezzymn

 

As you have correctly deduced, there is no option to show the Assembly hierarchy in 2019.  Depending on the version of 2019 you are using, I can provide a patch that brings back legacy behavior - let me know if you are interested.  As mentioned in my previous post, I am still keen to meet to discuss our the paradigms and workflows we have in 2019.

 

As a FYI, legacy behavior will return in 2020.  Additionally, Part hierarchy has never been shown in Model View, though this may change in the future.

 

 

 

 

 

Share this post


Link to post
Share on other sites
17 hours ago, ezzymn said:

Hi @tinh

 

set ::env(HMBR_CONTENT_HIDE_ASSEMBLYHIERARCHY_FOLDER)

can't read "::env(HMBR_CONTENT_HIDE_ASSEMBLYHIERARCHY_FOLDER)": no such variable

 

I feel like the functionality might be removed, but I appreciate you having a look. I've tried the crude attempt to copy over the 2017 files, but that segmentation faulted. 

 

Reports.7z 6.8 kB · 1 download

 

Many Thanks

Eric 

 

Hello

 

I modify some things

Please copy these modified files and overwrite the old ones

 

If something's wrong, simply backup original files and let me know issuesReports_modified.zip

Q.Nguyen-Dai likes this

Share this post


Link to post
Share on other sites

@tinh, Thank you I'll try and find some time today to try it. 

 

@joek, Sorry I haven't been ignoring you. I'll give this try from tinh a go, and if that doesn't work then a patch would be much appreciated

Share this post


Link to post
Share on other sites

Hi @tinh, in "Assemblies view" I can create Assembly/Component within each Assembly:

 

Assemblies_view.png.7260a3f8c6f9489dadee54d883615f09.png

 

But with "Model view" (your modified version) I can not do that (maybe the same issue in initial version):

Model_view.png.17e6f8e6e51811efa05d3a64b45df6e8.png

 

Do you think it's possible to customize this context menu by adding "Create ..." ?

 

Thanks,

 

 

Share this post


Link to post
Share on other sites

@joekI know you guys don't like to discuss product road maps on a forum like this, but will be there be another major dot release of 2019 HW suite (like 2019.2) before arrival of 2020 release (if we go by 2019 release time frame, it could happen almost 5-6 months in to next year)? There are lot of bugs and features missing, especially in HWX. I realize not all can be added or rectified but I am hoping for another major dot release to make HWX little more usable until 2020 release.

 

Thanks...

Share this post


Link to post
Share on other sites
1 hour ago, Burner2k said:

@joekI know you guys don't like to discuss product road maps on a forum like this, but will be there be another major dot release of 2019 HW suite (like 2019.2) before arrival of 2020 release (if we go by 2019 release time frame, it could happen almost 5-6 months in to next year)? There 

 

I deem persons before become HM developers should be HM users, so they could upgrade software better. Anyway it's a really good software because we can do almost things by Tcl ;)

Share this post


Link to post
Share on other sites
17 minutes ago, tinh said:

 

I deem persons before become HM developers should be HM users, ....;)

Yes, it's the ideal case. But in reality, that is not always true.

The "Model view" of 2019.0 & 2019.1 (with useless Assembly tree)  is a typical example of developers who don't take care of what users want.

 

Share this post


Link to post
Share on other sites
On 11/23/2019 at 7:53 AM, tinh said:

Yes, I do.

I will try hooking the menu. Just need a little time to find where it is.

Hi Mr. @Q.Nguyen-Dai

 

I seem to find it in hm2017

I don't have hm2019, could you please zip folder <install_dir>/hm/scripts/br  and post here.

 

Q.Nguyen-Dai likes this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...