Jump to content
Cui

DC-FSI error "'ABORTING RUN DUE TO UNEXPECTED ERROR CONDITION"

Recommended Posts

Hello everyone,

I followed the example of ACU-T: 5403 Piezoelectric Flow Energy Harvester: A Fluid-Structure Interaction in the AcuSolve 2019 tutorial.

However, I had error of ''ABORTING RUN DUE TO UNEXPECTED ERROR CONDITION'' and it didn't show any details about this error in both log file and stat file.

Can some one know why I had this error and how to solve it?

I also upload the .inp, .fem file below.

Thanks a lot!

slab_dcfsi.inp slab_dcfsi.fem slab_dcfsi.out slab_dcfsi.stat MESH.DIR.zip

Share this post


Link to post
Share on other sites

In your AcuSolve input file (slab_dcfsi.inp) you have in Auto Solution Strategy:  max_time_steps = 101.  With a time increment of 0.01 sec, the final time is 1.01 sec.  The tutorial instructions indicate to set final time to 3.0 - which matches with the final time in the OptiStruct .fem file.  Thus in your case, AcuSolve is going to stop at 1.01 sec, while OptiStruct expects to go to 3.0 sec.  AcuSolve stops, and causes OptiStruct to stop (error out).

 

If you set max time steps set to 0 and set final time to 3.0 on the AcuSolve side, as in Section 1.3 of the tutorial instructions, you should be good to go.

Share this post


Link to post
Share on other sites

hello everyone

I have to run a fluid structure interaction example with the method of DCFSI where Acusolve is coupled to Optistruct, I had an error " ABORTING RUN DUE TO UNEXPECTED ERROR CONDITION" as shown in the figure.I made sure that all parameters were correct .

Can someone know why I had this error and how to solve it please ?

I also upload the out files

Thank you in advance

ERROR.PNG

ailette-with-op.out cci.txt ailette_DCFSI.inp ailette_DCFSI.ss.inc

Share this post


Link to post
Share on other sites

The OptiStruct .out file suggests to look at the .stat file.  Does that give any ideas?  Can you also upload the AcuSolve .Log file and the OptiStruct .fem file?

Share this post


Link to post
Share on other sites

In AcuSolve, you've specified max_time_steps = 401, and final_time = 1E+1 (10.), with a time increment of 0.025.  The AcuSolve job will stop at the specified final time of 10.0, or after 401 time steps - whichever comes first.  Since 400 * 0.025 = 10.0, AcuSolve will stop after 400 time steps, rather than 401.

It looks like you've specified the OptiStruct job to do 401 time steps with a time increment of 0.025.  AcuSolve stops after 400 time steps, so the OptiStruct job errors out once the connection signal is lost.

Try setting OptiStruct to do only 400 time steps, so it matches the stop time of AcuSolve.

Share this post


Link to post
Share on other sites

I tried with 400 time steps both in optistruct and acusolve  it but it didn't work.the same error hads appeared.

Can you try it please ? .I upload the acusolve database file .acs and the optistruct .fem one. In fact, I obtained the output of Acusolve through acufieldview but I really need the output of the optistruct.

Thanks for your help and your support

ailette_DCFSI.acs ailette-with-f.fem ailette_PFSI.inp ailette_PFSI.1.Log ailette-with-f.out

Share this post


Link to post
Share on other sites

This ran through with both set to 400 steps as you last sent - using the latest (or close to) official releases of both codes - OptiStruct 2019.2 and AcuSolve 2019.1.  The only thing I can suppose is that the older version 2017.2 you're using (likely on the OS side) had a bug in the stopping mechanism that has since been fixed.  I've attached the OS .out file, along with the OS .h3d file.  Are you able to update your installations to the latest release(s)?

ailette-with-f.h3d ailette-with-f.out

Share this post


Link to post
Share on other sites

Thank you for the reply and for the file that you have sent.For the time being,I can not update the installation to the 2019 one.

we can say that the problem of the output h3d that must be generated  was in the software version(optistruct) ?

Thank you very much for your feedback and your lovely support 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...