Jump to content
Roshan Shiveshwar

Run SimLab scripts batch mode in Linux

Recommended Posts

Hi,

 

 I am trying to run a simple SimLab script in Batch mode on Linux environment.  I am getting the error: "hwx: cannot connect to X server".

 

Following  is the command that I am issuing -

$SIMLAB_SH_FILE -auto fe_modelling_simlab.py -nographics &

Is there any parameter that I am missing in the command ?  Or is it that GUI environment is required for running SimLab in batch mode?

 

 

Thanks,

Roshan

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Roshan Shiveshwar said:

On remote server.  Using "putty" interface.

 

In this case, you have to setup a X-Window server on your localhost and setup putty to export "DISPLAY" from remote to your local X-Window server.

 

Share this post


Link to post
Share on other sites
50 minutes ago, Q.Nguyen-Dai said:

 

In this case, you have to setup a X-Window server on your localhost and setup putty to export "DISPLAY" from remote to your local X-Window server.

 

 

I am trying build some understanding about "X-Window server".  So, will this work even if my localhost is a Windows machine?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...