Jump to content

Recommended Posts

I am using the full vehicle with driver.

and have gone through the help files available.

To perform various maneuvers I have edited the .adf file for event altairdriverfile, in the .txt format and then inserted it from the event editor tab.

For the .adf file I copied a existing .adf file from Altair library (Straight Line Braking)  and then added the following from 3D spline road data file available in the help section.

$-------------------------------------------------------------------------END_DATA_POINTS
[OBSTACLE1]
ROAD_TYPE 			= 'PotHole'
COORDINATE_SYSTEM	      = 'distance'
START 			    = 0.7
LENGTH 			   = 1.5
DEPTH			     = -0.007
$-------------------------------------------------------------------------END_OBSTACLE1
[OBSTACLE2]
ROAD_TYPE             = 'Curb'
HEIGHT                = 0.05
START                 = 0
ROUND_OFF             = 3.99805
TOP_WIDTH             = 1
EDGE_WIDTH            = 3

But it only performed the straight line braking.

How do I insert the code for it? ( I want to add a few bumps and drops) 

Share this post


Link to post
Share on other sites

Thank you 

 

1.) I tried simulating it, but it still continued to be a straight path only.

I have edited the file as the following 

Road Type = 2D FLAT

 

$---------------------------------------------------------------------ALTAIR_HEADER
[ALTAIR_HEADER]
FILE_TYPE  =  'rdf'
FILE_VERSION  =  5.00
FILE_FORMAT  =  'ASCII'
!
! road data file for TNO_flat_road
!
$--------------------------------------------------------------------------units
[UNITS]
LENGTH             = 'meter'
FORCE              = 'newton'
ANGLE              = 'radians'
MASS               = 'kg'
TIME               = 'sec'
$---------------------------------------------------------------------definition
[MODEL]
PROPERTY_FILE_FORMAT    = 'USER'
FUNCTION_NAME = 'mssticsub::ROAD'
METHOD             = '2D'
ROAD_TYPE          = 'flat'
$---------------------------------------------------------------------parameters
[PARAMETERS]
 OFFSET                      = 0
 ROTATION_ANGLE_XY_PLANE     = 180
 MU                          = 1.0
$
 DEPTH                       = -0.05
 START                       = 10
 LENGTH                      =0.5

 

(I am editing it in notepad and then saving it)

Please point out to the mistake. 

I want to create a pothole of the following dimension on the road.  (dimension in meters)

 

2) I have used the Vehicle Tools to create graphic files for the road files I am using (CRG,RDF) so I get an idea about the road graphically.

Is it possible to create a graphic file for the above code or for instance any .RDF or .ADF file given in the directory. How do I do it? 

 

 

3) How do you add ramps and potholes in .CRG file?
 

Share this post


Link to post
Share on other sites

There are three possible sources of error here:

 

 

1. Your tire data needs to be able to support non-flat road surfaces.  You have not indicated which tire model you are using (MF-Tyre, Fiala, F-tire, etc).  Tip:  look through the .log file, it will tell you what road file is being referenced, and what type of road contact.

 

For example, there is a flag to set in MF-Tyre for the type of road contact you want to use.  This has to be set correctly before the road file will be properly utilized.  Research "USE_MODE" in the MF-Tyre docs, if that's the tire model you want to use.

 

2. non-flat road surfaces typically required additional licenses.  Do you have the necessary license to run non-flat roads?  (Important note:  Our built-in enhanced Fiala tire model allows users to use non-flat road surfaces, for free.  It doesn't have the same level of fidelity as tire model like MF-Swift, CD-Tire, FTire, that all require additional 3rd party licenses.)

3. in "road type" in the file above, you still list it as "flat".  So, it's going to ignore any parameters you set.  You should look at  some of the many examples provided in the installation.  There are also examples provided with documentation for the particular tire model you are using (F-tire, CD-Tire, MF-Tyre, etc).

 

We currently do not provide tools for editing/modifying CRG files.  However, there are some open source tools available on the OpenCRG website.

 

If you want to create graphics for an analytical road surface like you are trying to use, what I normally do is create the geometry in Hypermesh, and put a simple mesh on it, and the export it as a .h3d file, which can then be loaded directly into MotionView as a graphical entity.

 

Here is an example of a pot hole road, taken from our installation folder:

$------------------------------------------------------------------COSIN_HEADER
[COSIN_HEADER]
FILE_TYPE  =  'rdf'
FILE_VERSION  =  5.00
FILE_FORMAT  =  'ASCII'
(COMMENTS)
{comment_string}
'pot_hole style road description'
$--------------------------------------------------------------------------UNITS
[UNITS]
 MASS               = 'kg'
 LENGTH             = 'mm'
 TIME               = 'sec'
 ANGLE              = 'degree'
 FORCE              = 'newton'
$-----------------------------------------------------------------------GRAPHICS
[GRAPHICS]
 ROAD_INCR = 500
$--------------------------------------------------------------------------MODEL
[MODEL]
 METHOD             = '2D'
 ROAD_TYPE          = 'pot_hole'
$---------------------------------------------------------------------PARAMETERS
[PARAMETERS]
 OFFSET                  =     0
 ROTATION_ANGLE_XY_PLANE =   180
 MU                      =   1.0
$
 DEPTH                   =    -50.0
 START                   =  1000
 LENGTH                  =   2000
 

 

Chris

Share this post


Link to post
Share on other sites

Thank You Chris

 

I am using the Auto-Tires 

 

FILE_TYPE                ='tir'
FILE_VERSION             =3.0
FILE_FORMAT              ='ASCII'
!
! FILE_NAME :         TNO_car205_60R15.tir
! TIRE_VERSION :      MF-Tyre/MF-Swift 6.2
! MF-TOOL TEMPLATE :  TNO_mfswift62          $Revision: 1.15 $

 

From the tire property file 

 

I tried using the TNO_Plank .RDF file but still the vehicle in the H3D model shows no simulation of going over the Plank it follows the straight path only.

(It is the original file in the library) 

 

Can you please provide your secure dropbox ID. 

 

Share this post


Link to post
Share on other sites

Did you check the USE_MODE flag in the .tir file?  What values is given there?

 

Another thing you may want to check is the orientation of the Road Reference Marker.  Sometimes this needs to be rotated about the Z axis 180 degrees, depending on the tire model and road file you are using.  Note there are probably two Markers, one for the front axle, and one for the rear axle.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...