Jump to content
Sign in to follow this  
JRego

Optistruct Requiring Too Much RAM

Recommended Posts

Hello there,

I've been trying to optimize a simple aluminium structure, using Optistruct. After defining all needed steps, I start up the optimization and the solver asks for 15GB of RAM to solve the problem. This seems to be a little too much, since it is an easy optimization.

The first iteration takes a long time to run and after that, the solver just freezes. 
How can I solve this? I will add the .fem file.

Thank you,

JRego

DV_EBS_05_01.hm

Share this post


Link to post
Share on other sites
2 hours ago, Q.Nguyen-Dai said:

How about your hardware? CPU? RAM?

I'm running a AMD Ryzen 5 3500U 2.10GHz, with 12GB RAM, only 10GB available. 

Share this post


Link to post
Share on other sites

You have about 463k nodes in your HM model. So your calculation has about 1,388,000 DDL.

So if Optistruct asks you for 15G RAM, it's not so much. In this case, I have to say you that you have too little memory to work correctly :P

You have 2 solutions:

  • Remesh your model with HEX element to reduce number of nodes => Optistruct need less RAM to solve
  • Add more RAM to your PC

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...