Jump to content
darad

Simlab 2019.3 LBC & Analysis changes

Recommended Posts

Altair, Please post Procedures to migrate Simlab 2019.2 or .1 models into 2019.3.

 

The Analysis icon at top is lost, instead there is a new Solutions icon.  Then Create a Structural solution asks to select bodies for a New Solution.   In the meantime, all prior entities in browser loads and BC tab are GONE!   

 

And then the Analysis icon at top re-appears.   This allows creating NEW loads and constraints which go directly to a new Load Case.   No longer separate collector for Forces and for Constraints, or able to create another Load Case.

 

The Solve cmd on Analysis ribbon is gone too.    I'm re-installing 2019.2, despite its lack of ability to change Units.

 

 

Share this post


Link to post
Share on other sites

Above behaviour (Analysis ribbon & exchange of database from lower to higher version )is intended for Simlab 2019.3 with student edition license.If you are commercial customer and have access to Hyperworks unit license,then above behavior should not occur.

 

Since this is the first release of Simlab Student edition, we dont allow exchange of database from full version to student edition.

Altair SimLab enables users to model and solve multiple physics with the help of newly added Solution ribbon tab.In Simlab SE, objective is to use Solution browser for different physics.Once you define solution, relevant physics based loads & boundary condition will get enabled for the the further setup of analysis.

 

For quick learning one could refer to below video for preprocessing/solving & post processing with Altair Simlab.

Share this post


Link to post
Share on other sites

I have full access to Hyperworks via corporate license tokens.  
 

yet I see the drastic changes in to LBC browser tab.    Model becomes useless without recreating LBC items, text and params, and load cases.   But then still cannot find Solve icon.  
 

for new models we are also stuck with the new unfriendly Solutions icon command structure ?   Too much is hidden from user.   Like iOS.  

Share this post


Link to post
Share on other sites

Could you please check the top left corner of the screen for Student Edition?Is there any student edition label like the below picture

Simlab SE.JPG

Share this post


Link to post
Share on other sites

No, header says Altair SimLab 2019.3.    I have no current desire to use the new Solution menu.

 

Only the old Analysis menu between FEM and the new Solution menu at top.   How to make Analysis menu re-appear???

 

I've reset Preferences, System, and check View, Application with SimLab checked. .... I see a SimLab X at bottom of 3 item list!   and deleted username... .Altair folder

 

It seems we ought not mix up the Student Edition in this dialog, as the length explanation above is highly confusing to me.   We have corporate license and tokens, and access to all Hypeworks product suite and Simlab.

 

LG at local Altair office just verified what I am see (but they are not!)

SL.png

Share this post


Link to post
Share on other sites

Uh-oh, my PC runs Windows 7.   Another user just installed on Windows 10, and the Analysis menu at top shows as customary.

 

Any other users with Win 7 vs Win 10 experience to share?   I informed altair support.

Share this post


Link to post
Share on other sites

Hello Darad

 

We have checked the issue which you mentioned in SimLab 2019.3 on Windows 7 OS machine and unable to reproduce the issue.

We are able to see both the Solutions & Analysis ribbon in SimLab 2019.3 which is configured using HW units.

 

The issue you reported may arise due to the License configuration of SimLab which is explained as follows

 

There are 3 versions of SimLab based on the type of Licensing.

 

1. SimLab HW units version - Supports both Classical & Solutions approach of solving.

2. SimLab sT units version - Supports only Solutions approach of solving.

3. SimLab EDU units version - Supports only Solutions approach of solving (Student Edition).

 

If SimLab 2019.3 is configured using HW units both the Solutions & Analysis ribbon will be displayed.

If SimLab 2019.3 is configure using sT units only Solutions ribbon will be displayed and after creation of the solution the Analysis ribbon will be displayed.

 

You can confirm the type of licensing which is used to configure SimLab by opening the Licensing dialog from File > Licensing inside SimLab.

 

Picture1.png.ced6ed21f1c94ff49f927daa42d30ef8.png               Picture2.png.fdb1ce977c8466acce1a573db89671e1.png

 

 

Kindly share your License setup image of SimLab 2019.3 so that we can check whether the issue you mentioned happens due to any Licensing problem or not.

 

 

 

Thanks & Regards

Nantha Kumar N

Share this post


Link to post
Share on other sites

Another user showed proper Analysis menu for 2019.3 on Windows 10.    So my Windows 7 installation is the exception here.   We have licensing with Hyperworks Units.    Sounds like the Student Version made 2019.3 quirky.   Please resolve.

SL Capture.PNG

Share this post


Link to post
Share on other sites

Hello Darad

As per your reply, we can see that the issue may not be due to Licensing problem.

 

As an additional check, can you verify the file ribbon.xml, which will be available in your SimLab 2019.3 installation directory.

The file can be located from C:\Program Files\Altair\2019\SimLab2019.3\bin\win64\xml\ribbon.xml" which is the default installation path.

 

After locating the file, open the ribbon.xml and check if the line <xi:include href="analysiswb.xml"/> is present in the file, as you can see in the below image

 

Picture6.png.faf84124ea53fc0a0dcc3ada42a90470.png

 

If the line mentioned above is not present, then the issue you reported might have been caused due to some errors during the SimLab installation.

So kindly Uninstall the SimLab 2019.3  in your machine and do a fresh Installation again.

 

Thanks & Regards

Nantha Kumar N

 

Share this post


Link to post
Share on other sites

    <xi:include href="analysiswb.xml"/> is present in ribbon.xml

Hence, I'll need to download the 4GB install file again, and re-install.

I am informed by Altair the Additional Files zip need not be present

for a normal installation without the frills (I did have the zip in prior install)

 

<?xml version="1.0" encoding="utf-8"?>
<Root xmlns:xi=" ">
    <xi:include href="meshingwb.xml"/>
    <xi:include href="geometrywb.xml"/>
    <xi:include href="assemblywb.xml"/>
    <xi:include href="FeaturesWB.xml"/>
    <xi:include href="femwb.xml"/>
  <xi:include href="solutionwb.xml"/>
    <xi:include href="analysiswb.xml"/>
    <xi:include href="OptimizationWb.xml"/>
    <xi:include href="ResultsWB.xml"/>
    <xi:include href="boltmodelingwb.xml"/>
    <xi:include href="caderrorcheckwb.xml"/>
    <xi:include href="crankshaftwb.xml"/>
    <xi:include href="gasketwb.xml"/>
    <xi:include href="midsurfacewb.xml"/>
    <xi:include href="onepushmeshing.xml"/>
    <xi:include href="pipes_tubes_wireswb.xml"/>
    <xi:include href="powertrainwb.xml"/>
    <xi:include href="processautomationwb.xml"/>
    <xi:include href="trialswb.xml"/>
    <xi:include href="weldwb.xml"/>
    <xi:include href="electronicswb.xml"/>
    <xi:include href="popupmenu.xml"/>
</Root>

Share this post


Link to post
Share on other sites

Altair:   How many successful install of 2019.3 within Altair on Windows 7?   

Users:   Kindly welcome to contribute experience, or test, so this gets resolved.

 

Maybe just DELETE Line with the dreaded Solutions ribbon which is causing havoc:

 <xi:include href="solutionwb.xml"/>

I can this before re-installing 2019.3 (after big download), and gain Admin rights again.

Share this post


Link to post
Share on other sites

Uninstalled and reinstalled 2019.3, no Win7 restarts.    Analysis menu displayed at top, miraculously.   Appeared functional to re-analysis of simple welded block assembly below, easily created in NX I-DEAS 6.1 -- still a super product, though on its way out :>(

 

1751032737_SLCapture.thumb.PNG.fa6f3ade6e90e77be9af2757de1265d5.PNG
 

Share this post


Link to post
Share on other sites

For anyone desiring the above simple welded STEP Assembly for learning/demonstration, here's the STEP for the simple assembly.    Better than demoing a monster transmission housing with a zillion features and dozens of bolted connections to impress (and intimidate).

 

For the welded-blocks, its this simple.

  • 2D mesh bodies
  • Join weld loop to base
  • Join block to weld loop
  • Join arm to block, e.g. MPC or Join
  • Note the block is nicely NOT joined to the base in the FEM
    • (no need to detach and reconnected edges where needed)
    • Slick process
  • Remesh bodies
    • to clean up the ugly mesh at interface
  • 3D Mesh solid
  • Mesh quality, compute, display, cleanup
  • Parameters and Outputs
  • Force and BC
  • Load cases
  • Data Check
  • Solve
  • Results

The arm can be joined or MPC to the block, as desired for demonstration.   The LBC browser can be used to great advantage to explain the process.

 

One can demo and teach the entire process:  import STEP to display results in 10 min.  Another demo assembly might include bolted joints with washer faces via mesh control, bolt spiders, bars, etc.   A way for new users to start quickly, and then delve into more detailed assemblies.  STEP assembly created in NX-IDEAS 6.1

 

TEST_SOLID_WELDED_BLOCK.stp

Share this post


Link to post
Share on other sites

Hello Darad

 

Glad to hear that the issue is resolved after reinstalling SimLab. Also thanks for sharing the Weld model with us.

 

Can we use the Weld model (TEST_SOLID_WELD_BLOCK.stp) which you shared, for our demo purposes?

 

Looking forward to your reply.

 

 

Thanks & Regards

Nantha Kumar N

Share this post


Link to post
Share on other sites

Yes, feel free to use this simple model for Marketing Demo's, which I created in my own free time.   Start to finish in 10 minutes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...