Jump to content
Tom_abc

Executed or not (depend on the monitor?)

Recommended Posts

Hi, I find a strange thing when I run the Embed. If I didn't use a "2D plot" or "display" block to minitor my variable (here "N"), the model seems not run at all. It told me "Not executed". See Fig1&2 and the vissim file. Could you tell me why this happens?

Fig1.png

Fig2.png

execute or not.vsm

Share this post


Link to post
Share on other sites

Hi Tom, 

 

The diagram when not connected to a plot has no intention to simulate anything hence you dont see any outputs. Vissim/Embed thinks that whole set of blocks is unconnected to any output so no need to evaluate the portion of this diagram. This is done so that if you take the current diagram and generate code you ideally want to see dead code being generated. 

 

As a workaround you could also insert a extern variable and connect it to the variable you would like to monitor so that you could still execute without having to connect a plot block !

 

Hope this helps

 

Hope this helps,

--sreeram 

execute and have an extern.vsm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...