Jump to content
Sign in to follow this  
shahrokh_sh88

urgent help! rigid to deformable body contact problem

Recommended Posts

hi everybody

a basic question!

has anyone ever modeled rigid to flexible body contact(not just a single point to deformable surface one) for multi body dynamics analysis in hypermesh or motionview?

if so,could you please help me with how to do that!

im really stock in that and i cant find any example or tutorial about the subject!

here is the error i constantly get:

"Parameter U=0.618718 goes out of intended range (-0.5, 0.5)!

Abnormal return from processing model!

Error encountered in analysis!

This error occurs in module "mbddrv"."

Share this post


Link to post
Share on other sites

Hi Shahrokh,

I'm a newbie to this forum!.. I have some Multi-Body Dynamics experience using MotionView / MotionSolve.

I just saw your post.. Are you all set with this?

Check out tutorials MV-1028 and MV-1029. They're tutorials based on the Point-to-deformable surface constraint and contact.. (rigid to flex contact that you're referring to below)

Let me know how it goes. I also have some contact details of people at Altair who can help you with this.. I can also share that with you if you're interested.

Ciao,

Dynamic_Guy

Share this post


Link to post
Share on other sites

Hi everybody!

I've got quite exactly the same problem as Shahrokh. I'm trying to create a contact between a flex- and a rigidbody. I already made the Tutorials mentioned above but the problem is that it is not possible to make a deformable surface out of my flexbody. I always recieve the error:

 

can't read "Xnode()": no such element in array
can't read "Xnode()": no such element in array
    while executing
"model$mangle AppendMdl "*SetPoint( p_[expr $BaseNumber + $additive], $Xnode($curr_node), $Ynode($curr_node), $Znode($curr_node) ) ""
    (procedure "::model::_private::Surface_Macro::CreateMarkers" line 364)
    invoked from within
"::model::_private::Surface_Macro::CreateMarkers"
    ("eval" body line 1)
    invoked from within
"# Compiled -- no source code available
error "called a copy of a compiled script""
    (procedure "::hwt::ReleaseCanvasButton" line 1)
    invoked from within
"::hwt::ReleaseCanvasButton 0 .modelPanel.surfCreate.btnGenerate"
    (command bound to event)

 

Could somebody help my understanding where my fault is?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...